Archive for January, 2016


January 2016 – News

First post this year (OK, second if you count the NY post). To avoid mixing up things, it consists of two parts.

  • Part One: my G751JY

My G751JY returned from Asus service center. They have replaced the mainboard. The good news is that the M.2 slot is still there. The bad news is that my Windows 10 Pro installation refused to activate on the new board. MS says you have to reinstall 8 and re-upgrade to 10. Windows 8 key will not work on Windows 10.

I AM NOT reinstalling the whole system and all my software…  So I’ve just tossed in a KMS activator and called it a day. I hate having to resort to such things, considering I have a legit Windows 8 Pro key, but I do not want to waste time reinstalling all my stuff because of M$’s upgrade policies.

Also, I’ve replaced my SM951 with a 500 GB EVO 850. I’ve decided that SSD space is more important to me than speed.

 

  • Part Two: PC service adventures.

I’m amazed how some PC vendors cheap out on parts. A new PC has arrived for service (built by a local computer shop), owner wanted me to install Windows 10. Since I did not have Windows 10 image prepared, I had to prepare it. I have installed Windows 10 to a VM, installed some commonly used programs and then sysprepped the system. I then imaged VMs hard drive to create the final installation image, which could then be used to install Windows 10 (along with my installed programs) on any system.

I did choose EFI boot when preparing the image, because that is what is most commonly used for new systems. But when I went to actually installing my Windows 10 image on client’s system, I was amazed. That system had a 6-core AMD CPU, 8GB of DDR3 RAM, a GT 750 Ti GPU and a 1 TB hard disk. Not a monster system but should be enough for an average gamer.

What suprised me was the mainboard. When I accessed the BIOS setup, I could not find any options for EFI boot… Strange, I thought (even my 2012 P67 board has EFI bios). Another strange thing was the BIOS date, 2013… WTF ?

Then I’ve checked the board model. It was an Asus board, but it was a 2013 (!!!) model, based on an ancient AMD 7 series chipset… Are you kidding me ? AMD 7 series chipset board ON A NEW PC ? That chipset is on legacy support mode already…

That means: no USB 3.0, no SATA 6.0, no PCI-E 3.0 and not even a UEFI BIOS…

 

And the vendor even managed to put a 500 euro price tag on that system. For extra 100 euros, the owner could have purchased a modern system with a last generation i5, 8GB RAM and a Geforce 950 GPU.

I do know that the computer shop which built that system is known to cheap out on parts on prebuilt systems (a Codegen PSU for example, is a common sight), but I really did not expect this… Using an old mainboard on a new PC ? Where did they even find that board ? Had it in unsold inventory pile ?

But let’s return to the EFI part. Since the system had no EFI BIOS, I had to convert my image to legacy boot. Fortunately this is doable easily. For those interested, here’s how it’s done:

1. Deploy your EFI system image as usual (I used Paragon HDM for creating and deploying images, but any other imaging tool will do).

2. Convert GPT partition table to MBR.

3. Delete EFI partitions: usually, there will be 3 of them: Recovery, EFI and Service. After deleting, resize OS partition to fill the empty space.

4. Mark OS partition as active (this is important for legacy MBR boot).

5. Boot from Windows 10 installation media (a DVD or USB flash drive will do), choose the Repair option.

6. Enter the following commands:

bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

Then reboot. The system should now boot using legacy mode.

 

New year (with rant…)

Another year of our existence has passed. Was it a good year or a bad one – you decide. Let’s hope the next year will be better than the previous one. But I think every year should have it’s dose of good things and bad things. That’s what makes life interesting.

Happy 2016 everyone !

 

Now, the actual news.

I normally would never write bad things in a new years post, but this year, I’ll make an exception.

My G751JY suprised me this Christmas… by dropping dead. No boot, just 1 minute of fan humming and then automatic poweroff. Tried removing all parts I could access by removing the bottom cover – didn’t help (didn’t want to go further to avoid losing warranty). BIOS recovery didn’t help either. I suspect it’s a mainboard failure.

I had this lappy for only 3 months and it died… Dammit ASUS, I really expected better build quality from a high-end laptop costing 1.7K €!!! I RMA’ed the lappy and waiting for it to be repaired.

Didn’t even have the chance to test my new SM951. I did ask the service center to make sure the replacement board has the M.2 slot (I know some later G751JY models lack it). I’d really hate to have to return my SM951 due to lack of a slot.

Now I’m thinking about buying a warranty extension. This lappy costs 1.7K € and only has a 2 year warranty. I definitely would NOT want to trash that system after only 2 years !

 

Copyright © 2008-2015 DDS Central. Powered by WordPress. Theme: Motion (modified by DDS Central)