Archive for August, 2009


Virus Alert !

Recently found that some of my programs (in Creations folder have been infected by a Delphi virus (Win32.Induc.a). This virus is harmless, all it does is infect Delphi to add itself to compiled EXEs. The code added infects Delphi installation (up to Delphi 7) when infected EXE is run. It seems that this virus has been in the wild for a while (I’m detecting it in EXEs compiled three months ago) but was discovered only very recently.
I will re-upload disinfected copies of the infected programs now.
Also, more than 50 of my other compiled EXEs had this crap in them.

I was reading about this virus and even found the code it adds to compiled EXEs. Just didn’t think that my own Delphi installation could get infected.

Also, my ISP was complaining about the virus activity in one of my PCs. I found and removed the freakin’ Conficker worm from my secondary PC. The good thing that this worm did not do any additional damage (like disabling Safe Mode) to the OS.
It seems that the worm did not infect any of my other PCs.

Second monitor died

The secondary monitor I used for my second virtualized PC died (it is a 19″ LG widescreen LCD). It was turned off and now it would not turn back on. It seems that there’s no power at all (I’m suspecting a dead power supply board). The good thing is that the LCD is still under warranty, so I will RMA it.
But my second virtualized PC is useless without it’s monitor, so I will have to use my main PC until the monitor is fixed.
That reminds me that there’s some other hardware that needs to be checked (eg. PSU in my main PC emits strange sounds at startup).

I’m also trying to fix a Toshiba laptop (in a very bad condition: LCD cracked, touchpad does not work, hard drive going bad, DVD drive dead)
I was asked to reinstall XP, so I used a RIS server (on my Win2003 VM) which formated the HDD. That normally would not be a problem (most PCs I repair are used as DVD or music players, so the data is not important) but it turns out that there was some valuable data in second partition (the drive had 2 partitions) which is now inaccessible. I’m trying to get that data back somehow. The process will take very long time due to a damaged HDD (lots of bad sectors).
This laptop has seen a lot of bad things in it’s life.

That’s all for this time.

P.S.: I usually ask people whether they want me to backup their data, but this time I forgot to do it.

Ads!!

Our host just placed Google ADS in our blog.
Well, injecting your own HTML crap into someone else’s page is kinda annoying to me (well, I don’t get paid for their Adsense ads), but we’re using a free hosting provider (as we don’t have too many visitors) and there’s a saying: “You get what you pay for.”
The ads should go away after a week.
I hope they don’t bring them back again. Or I probably will have to look for another hosting provider.

Downtime

Our host messed up something on their servers (it has something to do with their ads), so our blog at ddscentral.co.cc went down (just the site, email was ok). If you see this, we’re back online now.

Site problems are not that kind of stuff I like to have.

Uuppddaattee!! part 3

VM Software updated.
Too bad that it expires after 2 weeks. Fortunately, simply setting the system date back works. I hope they will release a retail version until then. If not, I will have to set the date back to continue using the beta version when it expires.
That’s not a big deal though.

That’s all (there will be no part 4).

Uuppddaattee!! part 2

Ok. About those two PCs.
Fixed one of them. XP did not boot at all. Booted PC from XP Live CD and found a damaged partition (and a crappy loud Maxtor HDD) that I could not access.
Ran Paragon PM 10.0 Live CD and repaired the partition. XP booted up and showed a “Checking Drive C” screen. Then booted to desktop and worked as normal.
This damaged parition may be a sign of failing HDD. I did not scan the HDD for bad sectors (due to lack of time).
There was Kaspersky AV installed but it had no valid lic. key so it did not work. I ordered a renewal for Kaspersky and also bought a 320GB mobile hard disk.
Second PC did not have any problems except that it was slow and had some crappy half-XP half-Vista skin installed. That one had just 256MB RAM (the first one had 51MB2 RAM).

Also, some good news and some bad news:
The Good:
Fixed a PC and got paid.
Bought additional 320GB of external space

The Bad (or not?):
Found an update for my virtual machine software, VMWare WS 7.0 Tech Beta. It had many new features, including an updated 3D with SM 3.0 support.
But the damn installer doesn’t want to work at all.
Edit: OK, got it to work somehow, will post back all is done.

The strange thing is that that “private beta” is available for download if you know where to look at: Here’s the link (registration needed)

Uuppddaattee!!

No posts for this July (Darn!).
Here’s some news. I will not go anywhere to buy the Bluray. There are some people how will get it and send it to me.
Also, I will be fixing a couple of PCs tomorrow. One has a problem with some application not working properly, the other one has Win installation messed up.
Will post the results tomorrow.
That’s all.

Copyright © 2008-2015 DDS Central. Powered by WordPress. Theme: Motion (modified by DDS Central)